Fold All / Expand All

2017年4月8日 星期六

Angular 4.0.0

咦…這樣是不是標籤就不能用 Angular2 了啊

在2016年9月14日推出正式版 2.0.0 後,Angular 持續以驚人的速度,不斷推出新版本

是說每週跳個 minor 或 patch 也還好

http://angularjs.blogspot.tw/2017/03/angular-400-now-available.html
但才半年,就跳了 major,宣稱 backward compatible with 2.x.x for most applications
(謎:禾斗禾斗,most applications)

https://github.com/angular/angular/blob/master/docs/RELEASE_SCHEDULE.md
不知道為什麼跳過3,原以為是要走偶數 stable,但從 release schedule,之後會有 5, 6, 7,看來也不是這個路線,單純跳過 3?

然後 release schedule 是2017年的9或10月,就會有 5.0.0,相容到 4.0.0

也就是說,一年後的版本,就和現在的不保證相容了

因為跳槽之後,就沒有再追蹤最近的比較,不過看起來對 Angular 2/4 的評價還是得等等,要先有足夠大量的 tutorial 啊

沒有留言: