Fold All / Expand All

2016年7月23日 星期六

Browser Compatibility of Ext JS, Angular, React

Angular 1

What browsers does Angular work with?
https://docs.angularjs.org/misc/faq
↑這裡提到 Latest Chrome, Firefox, Safari, Safari for iOS, IE 9-11
沒說 Edge, Chrome for Android, 舊 Opera

較早的版本 Angular 1.2 有 IE 8 支援,從 1.3 drop support,目前最新是 1.5

React

Browser Support
↑支援流行的瀏覽器,包括 IE 9 和以上

Discontinuing IE 8 Support in React DOM
↑IE 8 support 從 v15 停止支援

Redux 的話,有些討論
↑原則上看起來是掛 一些 es5-shim

Make your React app work in IE8
↑也有這類集中討論

Ext JS

Supported Browsers
↑連結是 6.0.2,不過裡面有各版本的支援狀況

這算是 Ext JS 的特色吧,到了 Ext JS 6,在 classic toolkit 仍支援到 IE 8,也有標 Opera 12 (雖然這個不太重要…)

Angular 2

目前還沒看到有官方文件列出支援瀏覽器列表,只有一篇 blog 文章說,看 GitHub 上的 ci 狀態

Angular2 Browser Support Announced For IE9, Android 4.1, And iOS 7.1

按照這篇提的,是要支援 IE 9,不過從看到這篇以來,每次刷 GitHub,IE 9 那格永遠是紅的啊…

沒有留言: